Forum for discussing Cursed Stone.


Postby Shadow_Sam1 » Mon Apr 02, 2018 5:18 am

I’m in the Abyssal Canverns and I’m using the teleport, I push the button on the wall, I have tried to hit the walls to see if they are fake walls but I’m stuck... i tried to hit the pillar and nothing has worked.
Posts: 31
Joined: Fri Mar 30, 2018 3:58 am

Re: Hey-Brasil

Postby Catacomber » Wed Apr 04, 2018 3:14 am

This is a full solution of the puzzle
There are 4 switches in the room, two on walls and 2 on the floor. The two on walls are a secret switch and a lever.
Those on the floor are labelled “Activate” and “Reset”. The second should not be used unless you lose track of the sequence. Stepping on it will make it necessary to do the whole sequence again.
When you come in walk N to the sign. It reads “O.S. was here. Twice.” Turn Left and press the button twice (no more or you have to reset the system)
Walk south to the Activate floor switch. As you step on it you hear walls moving. There is now a passage open to the South. Follow it to the switch and throw the switch. The wall sign now says “Twice. Activate”
Walk back to the push button press it twice. Walk south and step on the activate button. You hear walls moving
Now there is a passage behind the reset button. Do not step on the button (you can get out behind it) or you will have to repeat the procedure.
User avatar
Posts: 1523
Joined: Tue Oct 25, 2011 5:20 am
Location: New York City

Return to Cursed Stone

Who is online

Users browsing this forum: No registered users and 1 guest