The Quest Guides Part 6: Level 10-12 Quests

Guides and walkthroughs.

The Quest Guides Part 6: Level 10-12 Quests

Postby Sylon / Redshift » Sun May 06, 2012 12:30 am

A collection of lost guides from Playhaven, focusing on the third town of the game (Phryn).


Steal the key for slave's chains

A small guide for the side quest "Steal the key for slave's chains"

The guide is consise, but the quest is easy :-). The only thing is to be skilled enough...

First go to Ancestors' Bay east Shore. Fnd the Orc slavers, and talk to the slave girl. She'll ask you to steal the chain's keys from the drunken orc slaver.
Find him in the house closest to the slaves. Talk to him and choose the second option in the dialog. You need at least 40 stealth and 40 persuade skills (I'm not sure of the exact skill level, but I'm sure you must have high persuade).

Once you have the key, go back to the slave girl, and talk with her.

You'll probably end into the pit in the center of the village. Press a hidden button to go back to the surface.

Increased fame, and a ruby gem.

Written by graoarg


John's guide to finding and killing the Witch Queen

A note before you start the quest!
If you have poisoned the chief of the goblin's before you complete this quest you cannot complete this quest! The witch queen will appear, steal your hammer of witch killing, and disappear forever. So..... Don't kill the goblin chief until AFTER you complete this quest. Thanks to BlackJack992 and Mervin2012 for pointing this out to me.

Starting the Quest

If you haven't already you'll need to head to Long Spit Village - East. There you'll need to talk to Waheetu the Goblin Elder. He (or she?) is located next to the pit, which is used as the village jail. I haven't been tossed in there (and am not sure you even can), but Waheetu makes it sound like a pretty bad place.

Long Spit Village's location

Waheetu the Elder's location

Waheetu the Elder

Like I said before, you'll need to talk to Waheetu. Waheetu will tell you all about how the witches are encroaching on the Goblin's land. Eventually the conversation will end up with Waheetu asking you to go eliminate the Witch Queen. Supposedly this Witch Queen is a pretty bad lady, and Waheetu will supply you with a special hammer that you can use to kill her. I imagine that if you don't have this special hammer you cannot kill her, so it's important to get!

Where the hell is this Witch Queen lady?!

I think this is the place where most people get stuck on. I had to wander around for an hour or so to find this place. The problems that I ran into are two fold. First, to the east of Long Spit Village you'll find some witches running around. This will lead you to believe that you should find the Witch Queen to the east. Well that's a faulty assumption.

The next problem that I ran into is that the Empire of The Witch Queen actually has two entrances. The one that is closest to Long Spit Village is actually completely useless to you until after you complete the quest, so if you end up finding it first it can be quite irritating. It took me 30 minutes of romping around to find the other entrance. I'll try to save you guys some time and show you where you need to go. Please keep in mind that on the far west end of the Fen of Death you'll run into a wall. You'll need to pay the guard 50 gold to get through.

*A note about the Fen of Death*
In the Fen of Death you'll run into about a million plague traps. You'll see these as bubbles on the ground (ala the poison cloud traps you've run into) but the bubbles will be black. Because of this you'll need to have a huge collection of Cure Plague potions or be able to cast the Cure Plague spell.

The wrong place to look (right now)
Map ; The wrong entrance - The Torture room

Zoomed ; The wrong entrance - The Torture room

The place we need to go

Map ; Correct entrance

Zoomed ; Correct Entrance

Cleaning out the Queen's home

I'm sorry to report that I did not keep a tally of the creatures in this area. There are a lot of enemies, and almost all of them can inflict some sort of status effect on you. From what I remember we have all flavor of witches in the cave, evil eyes, the Queen herself, and even a couple Blood Ghouls. Because of this you'll want a large collection of potions/spells on hand to cure all maladies.

I also did not keep track of the things that you'll have to actually do to accomplish the quest itself. I can tell you that inside the Realm of the Witch Queen it is fairly straight forward. There isn't anything in the way of puzzles or tricks you'll need to do. Just go through the area clearing everything out (and picking up a very good selection of loot/gold) and you should be golden.

When you get to the Queen toss on your Witch killing hammer and go to town. I was level 15 when I tackled this quest and it was fairly easy. As long as you keep a large stock of potions you should be fine.

*Note about the Teleporter*
Michele_Laconto reminded me that I should say something about the teleporter located in the Queen's Realm. At one point you will need to teleport into a crypt in Mithria. There is a locked door in the crypt that you cannot unlock. So don't freak out when you can find a key for it! Thanks Michele_Laconto!

The reward?

Not much. Once you kill off the Queen you can run back to Long Spit Village and talk to Waheetu again. He (she?) will be happy, praise you, and give you a measly 800 gold. You do get to be an honorary judge in the beer tasting competition though!

A disclaimer..

This is my first guide so please be kind. I noticed that no one had made a guide for this quest while I was wandering around trying to find the second entrance to the Realm of the Witch Queen. I didn't have the idea for making the guide until after I had finished the quest. That's the reason I can't help much once you get into the Queen's Lair. I honestly don't know if there are any other ways to end the quest, or if it branches in any way. I've only been through the game one time. I just figured a substandard quest guide is better than no guide at all. If people point out something that I forgot/did incorrectly I'd be more than willing to add it in. Just tell me what I've done wrong and I'll stick it in and credit you!

Written by johndra


Killing the Cyclops King, (in Silver Peaks Mountains)

This is for you noobs who keep asking about Silver Peaks

Okay, go south of the peaks until you reach a group of farmers. One of them will be named miller. He will give you a sword to kill the Cyclops King and the quest. The sword doesn't work (surprise). Go to the enchantress to the south. She fixes it. Go kill the Cyclops King. Flip all the switches it the mountains. Yeah! Quest over. You can now move on in the game!

Written by tiktax346


Guide to Finding Juliana, The Enchantress' Head!

Here it is! How to find that darn head!

Go to the Village of Phryn and talk to any village person walking around. Ask 'Anything unusual?' in the dialogue.
They will tell you to visit the mayor (he lives in the northwesern part of Phryn) and to the Enchantress Juliana's neighbor Aria (she lives in the south eastern part of Phryn). Aria will tell you the man she saw with Juliana looked like the mysterious man living in Skryven Keep (to the west of the village) and also he resembled the blacksmith, Brom.
The Mysterious Man has nothing to tell you. The Mayor of Phryn will tell you there was a mysterious knife found near Juliana's body.
Go see Brom the blacksmith. Brom tells you he only went to the Enchantress for potions for his wife, Tiria and her lover, Bomur the Soldier. He will send you on a quest to bring them the potions.
Their house is a little south and all of the way east, almost to the coast line and Bomur the Soldier will be walking around outside behind the house. Ask them about Juliana before you give them the potions! Both, Tiria and Bomur will tell you of strange happenings at the curio shop.
Go to the Curio Shop (It's on the backside of the Blacksmith's shop) and talk to the owner, Unaak the Seller. He will give you a skull. Bring it to the mayor. The mayor will have you wait a day or so, to be sure it's Juliana's skull. Check back for your reward.

Written by Michele Laconto


Guide to Finding the Thieves' Transport

You will first need the quest from the Mysterious Man of Phryn or they won't be there.
They are located in the area of your map called, "Lake of Freymore - Southern Shore". The easiest way to find them is to start in the Marsh of Reeyk, in front of Reeyk's door.
From Reeyk's door you'll turn and face north, walk 6 paces. Now, turn and face east. Walk 19 paces. You should now be standing in the middle of the Thieves' Transport.

Written by Michele Laconto


Guide to Killing the Cyclops King

How to start the quest, find and kill the Cyclops King and extra info about the Silver Peak caves.

Silver Peak entrances

Location of miller and farmers

Find the miller, south of the Silver Peaks in a patch of grass with farmers. He will ask you to kill the cyclops king with a blade from an Enchantress. Go into the Entrance of the northern part of the Silver Peak caves, find the Cyclops King, and try the blade. It doesn't work. Go back and tell the miller and he will send you to Elena the Enchantress' house.
Elena's house is to the south and a little east of the farmers. she will re-enchant it for you.

Location of the Enchantress' house

Go back to Silver Peak caves and kill the Cyclops King. After you kill him you will get a 'Cyclops Key' it opens the cell to the south that Benan the apprentice is. He will give you the 'Bloody Cyclops Key.' this key opens the bone gate to the east. There is a switch for the invisible room on the wall to the north.

There are five switches for the invisible bridge in the caves. Three switches are in the northern part of the caves, two are in the southern part. One of the switches has a witch blocking it and another has a shaman and Orc blocking it. You need to annoy them in the dialogue so they will attack you, otherwise, you won't be able to flip them.

Location of switches (north cave)

Location of switches (south cave)

If you take on the blacksmith of Mithria's mithril quest, the mithril mine will open up in the area of the 'Temple of the New Era' located in the southern caves.

Written by Michele Laconto


Guide to The Thieve's Guild and Other Mysterious Man of Phryn's Quests

This guide will get You into the Governor's Castle, help you join the Thieve's Guild and easily get you through the Undead City!

You will find the Mysterious Man in the Tower of Skryven Keep just west of the village of Phryn

Question The Lord of Mithria
The first quest he sends you on is in his basement to question the Lord of Mithria. Easy one to do.

Turn on The Center Teleport
When you get to the city of Mithria, you will be able to touch the red magical barrier in the southeastern section of Mithria to the teleport. You will be able to teleport to and from Phryn.

The Governer's Necklace
Next, he will send you on a quest for the Governer's Necklace. To get the necklace, you need to start in the port of Mithria. Go to the western side where Captain Hanty is. There will be a Suspicious Man there that you need to ask about the Governer's castle. He will ask for $5000 gold. You can get him to do it for $2500. Be ready because he will send you to the Sunken Island as soon as you pay him.

Sunken Island
When you arrive at the Sunken Island, you will need to kill a bunch of skeleton guards. (pick up any old stale and rotten food you may find- you'll need it later on). You probably will notice a hole in the ground that says, "Strong magic prevents you from entering." Find Wawirr he lives on the east side of the house that looks like the letter "H" on your map. He wants you to pay to enter the hole. He won't accept gold, you must give up more! You need to give up 2 points of one of your attributes:
I haven't found a way around it.
Climb down into the hole. You'll battle some Venom Bats and Bloody Skeletons. After you find your way to the end, go up the ladder and go in. No one is behind any of the doors. (you may want to save your game or mark somewhere inside because if you accidently go out of the castle...) There's some loot around the castle you can pick up on the way. Go up the stairs to the east wing. Make your way to the end where there's a small door with a guard to the south and a large double door to the north with two guards. Talk to the Palace Guard Captain by the small door and he will give you access to the large room (workroom) across the hall. Get the Governer's necklace and bring it back to the Mysterious Man in Phryn.

Kill the Mage Council Leader
Go to Mithria and find the Mage Council building. It's located in the eastern part of Mithria. If you stand in the large gate in the area of the Mayor and Governor and walk east until you are at a door, that's it. Go inside and go upstairs to find the Mage council leader. After you take care of him, go back to the Mysterious Man. Take on your next mission.

Join the Thieve's Guild!
Before you start, in the dialogue, if you mention to the Mysterious Man about the items he's after are probably under special locks... He'll give you a couple of scrolls- strong disarm and strong unlock (they come in handy later).
-Find the Thieve's transport
It's located at the southern shore of Lake Freymore. Also he will tell you that the door to the Thieve's Guild for you right now, is the inn. Find the transport, talk to the leader and take the goods back to the inn in Vastares' port quarter.
-Talk to the innkeeper in Vastares' Port Quarter
Ask him about 'goods' then tell him you will 'stay around until midnight'. Leave. As soon as you step outside, two suspicious men catch you and take you to the Thieve's Guild. Talk to the Guild Leader and he will send you on a mission.

Rob a wealthy family in Mithria
When you are transported out of the guild, remember this spot. Touching the lantern on the wall will get you back into the Thieve's Guild. The house you are looking for in Mithria, is directly south of the Mayor's house. The door will be unlocked (make sure you have a lockpick, unlock spell or scroll to get the jewels out!) You can buy a lockpick from the locksmith or you can use the unlock spell or scroll from a magic shop. You may want to have the disarm ability or spell also. After you get the jewels, take them back to the Leader of the Thieve's Guild. He will then give you a key to the Thieve's Guild. The key works on all of the blue doors in there. When you find the red door, you may need to use the strong unlock scroll on it. (My lockpick ability is 50 and it's not high enough to unlock it with a pick). When you get the red door open, get all of the items inside the room and bring them back to the Mysterious Man in Phryn.

Enter the Undead city
Go to the military encampment outside of the city of Mithria. Go to the door that's in front of the hole there. Talk to the Army Guard inside. You should have gotten the Governer's necklace back from the Mysterious Man. You will need to give the necklace to enter the undead city. Talk to Yuaar, the Mayor of the Undead. He will tell you to help his people. When you leave his house, go to the south where the rope is hanging down, then go west until you see a spider web. Cut it and cross the bridge. Go to the northwest corner and pick up the Dark Maul. Cross back over the bridge and go find Marusyma's house.

Find Marusyma's Sister Eleta
Marusyma's house is just south of the inn, next to a spider web. After you talk to her, head to the soutwest corner to find another bridge. You can't cross it because of rocks blocking it. Smash them with the Dark Maul. Cross and find all of the spoiled food and talk to Eleta, Marusyma's sister. Go back to Marusyma's and talk to her. Now, go to the inn and talk to Rotto. He will take rotten food and water from you. You can sell him the rest. Go back to the Mayor and ask about the Governer. Go back to the Mysterious Man. He will then send you to the north-east island for the"Returning". You need to be at least level 14 to be taken there.

Location of the Thieve's Transport!

Stand in front of Reeyk's door. Turn and face north. Walk 6 paces. Now, turn and face east. Walk 19 paces. You should now be standing in the middle of the Thieves' Transport.

I hope this helps!!!!

Written by Michele Laconto


Guide toTreasure Island (a.k.a. Island of Ghula)

How to get the map, get to the island, find the skull key, open the Pyramid of Ghula, get through it and get back to Freymore

Find Gorjan in the Village of Phryn.

Gorjan's House

His house is near the mayor's house. He will give you the map for $1000. Find captain Hanty in Mithria's port near the inn, he's the only captain that seems to know where Ghula, the Treasure Island is. Be ready. You're going to be dropped off without anywhere to get supplies.

Cross the bridge ahead of you that's a little to the northwest. Watch out for the Specters. Go to the northeast until you see a pink building type structure a little to the east. Make your way around to the north side. Go into the entrance. This is the home of the Skull Keeper. Kill him and get the skull. There's a restore health and a restore mana Sphere here also.

When you leave the entrance, go 2 paces north, then 14 paces to the west and then 4 paces north onto the switch plate. Turn and face south again, go 3 paces. Turn and face east, go 26 paces, turn south, go 20 paces (you should be at the Pyramid of Ghula), then go 4 paces east and touch the pedestal. Turn to the west and break the cracked wall to reveal the entrance.

When you get inside, you will be killing Mummies and Ancient Mummies. Go up the stairs into the room with the pillar in the center. Cut the spider web on the north wall and flip the switch. Go back down the stairs. The pillar to the north in the hallway that you are in has moved.

Watch your compass! The directions change from area to area!

Go down the rope. Find the small button on the wall near the pot. Ignore the transport for now, we'll get back to it. Go back up the rope, then the stairs and back into the room with the pillar in the center. Now the green barrier by the stairs to the south is gone.

Go down the stairs and then down the rope. Find the button on the wall by the pot (look south- it's harder to see). Don't worry about the stairs to the south yet, we'll be back. Go back up the rope and back up the stairs into the room with the pillar in the center. Another green forcefield is gone.

Get the Green Pyramid key from the shelf. Go back down the stairs to the south, and down the rope and down the stairs and open the door.

Here we are at the teleports. Step in the one to the east, step backwards to the north to get the items from the shelf. Step north now east. You should be back at the doorway. Now step in the east teleport again. Now south, east and west. Turn and flip the switch. Go north, north, north and then east to get back to the doorway. Go back up the stairs, up the rope, up the stairs into the room with the pillar in the middle, then down the stairs to the west, down the rope and into the teleport.

Go straight across the room and flip the switch.Forget about the doors in this room for now. These doors will close on you if you don't go in the right ones. Go back to the teleport and the wall will now be open to the south. Make sure you flip the switch on the west wall of this room. Take the teleport again. Go into the open doors on the east side where the blue door is. Get the Red Key and Blue Key from the statue. Open the blue door and the gold door and get the idols from inside. Don't try going through the tall doors on the west side where the gold door is or they will close on you. Go back into the teleport and the room to the south. Place the Brass Idol on the shelf that says, "Holy of Brass" and the Gold Idol onto the "holy of Golden" shelf.

Get into the teleport there. Now go through the tall doorways to the west. Grab the items off of the shelf opposite of the teleporter (you need to bring these items back to Gorjan in Phryn). Jump into the teleport. You'll end up at the port of Matras. Get back to Gorjan in Phryn with the 'Rusty Armor'.

Written by Michele Laconto
User avatar
Sylon / Redshift
Posts: 611
Joined: Sun Oct 09, 2011 9:23 pm
Location: Hungary

Re: The Quest Guides Part 6: Level 10-12 Quests

Postby Marc487 » Mon May 28, 2012 5:35 pm

On killing the Witch Queen, if you kill the goblin cheif and die when you are taken to the cave, you respawn in the village, but you have the witch hammer, and the goblin horn. A little glitch I'd like to point out.
Posts: 15
Joined: Mon Feb 13, 2012 5:01 am

Re: The Quest Guides Part 6: Level 10-12 Quests

Postby RavishingTurnips » Fri Aug 17, 2012 8:58 am

Help! On the Enchantress' Head quest, I gave the woman and man the potion and drink before talking to them about the Enchantress! I can't reload the save and it annoys me sitting on my quest list! Is there a way around this??
Posts: 1
Joined: Fri Aug 17, 2012 8:56 am

Re: The Quest Guides Part 6: Level 10-12 Quests

Postby appthief » Mon Aug 20, 2012 12:50 pm

@Ravishing Turnips,
I've done the same thing. I don't think it matters. If you got to the point where you delivered the potions, you should be able to go to the curio shop and get the skull to give to the mayor. I've never talked to those two (the man & woman) prior to giving them the potions. Everything still worked out :D
I may not be fast, but I am constant.
User avatar
Posts: 17
Joined: Wed Aug 01, 2012 3:32 pm
Location: Iowa

Re: The Quest Guides Part 6: Level 10-12 Quests

Postby appthief » Mon Aug 20, 2012 1:42 pm

You can get a quest from Karmish the Slave Master and complete the 'Steal the key for the slave's chains' quest.
While talking to Karmish to steal the key, you have a chance to accept a quest from him. Choose option 1 in the dialog to get the quest. You will get a bag, for slave orders, to fill. Then steal the key for the slave's chains from Karmish. Go to the port of Mithria and talk to captain Hanty about the slave orders. He will fill the bag. Go back to Karmish the Slave Master and give him the full bag. Then go and release the slave with the key.
I may not be fast, but I am constant.
User avatar
Posts: 17
Joined: Wed Aug 01, 2012 3:32 pm
Location: Iowa

Re: The Quest Guides Part 6: Level 10-12 Quests

Postby Bellbane » Mon Jan 21, 2013 1:04 am

Undead characters don't have to pay the attribute points on the sunken island. ;)
Posts: 27
Joined: Sat Jul 21, 2012 2:50 am

Re: The Quest Guides Part 6: Level 10-12 Quests

Postby Boom34 » Sat Apr 13, 2013 11:06 pm

Is the killing the cyclops quest bugged? I take the blade to the enchantress but i dont get the "about the blade" option so i cant kill the cyclops.

Also, I can't kill the mage council leader because he keeps teleporting away, any ideas?
Posts: 7
Joined: Thu Apr 04, 2013 9:50 pm

Re: The Quest Guides Part 6: Level 10-12 Quests

Postby DeMenchev » Sun Apr 14, 2013 5:44 am

To slay Cyclops King:
1. Take the Cyclops Blade and this quest from Miller
2. HIT Cyclops King with it at least once
3. Tell Miller the news
4. Go to the enchantress and exchange the blades
5. Kill Cyclops King!

No need to kill the leader. Just go and tell Mysterious Man the news.
Posts: 252
Joined: Wed Jun 13, 2012 6:00 pm

Re: The Quest Guides Part 6: Level 10-12 Quests

Postby The Questman » Fri Mar 20, 2015 1:03 am

You can't kill the Mage leader its part of the game
I am as bad as the worst, but, thank God, I am as good as the best.
The Questman
Posts: 16
Joined: Wed Dec 31, 2014 11:00 pm
Location: LV NV

Re: The Quest Guides Part 6: Level 10-12 Quests

Postby Prickett » Fri Mar 20, 2015 11:14 am

You don't have to kill the mage leader when you encounter him in Mithria. Just take the vial back to the strange man. And for future reference, if you have any questions about the game, please post in the "general discussion" page. "Guides" is for posting a guide to do something, not questions.
Posts: 613
Joined: Mon Jul 22, 2013 2:39 am
Location: Georgia, USA

Return to Guides

Who is online

Users browsing this forum: No registered users and 0 guests